Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 29, 2025 - 23:00 GMT
Scheduled
We will be performing essential cabinet maintenance to enhance the resilience and performance of the Somerset network. The work is scheduled to begin at 23:00 and may result in a temporary service disruption lasting approximately 10 minutes.
We appreciate your understanding and cooperation as we carry out these improvements.
Posted Oct 29, 2025 - 13:46 GMT
This scheduled maintenance affected: Internet Network (Devon & Somerset).