Unplanned outage-Compton Martin (South West)
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 16:55 GMT
Investigating
We have identified an offline cabinet currently affecting services in this area. We have engaged our teams who are working diligently to investigate the root cause of this issue and implement any repairs as quickly as we can.

Please accept our apologies for any inconvenience caused.
Posted Nov 18, 2024 - 12:53 GMT
This incident affected: Internet Network (Devon & Somerset).