Cabinet Issue - Cavendish, Sudbury, Suffolk
Incident Report for
Gigaclear
Resolved
This incident has been resolved.
Posted
Apr
10
,
2025
-
08:10
BST
Update
We are investigating an issue affecting customers attached to the cabinet in Cavendish, Sudbury, Suffolk.
Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted
Apr
09
,
2025
-
15:00
BST
Investigating
We are currently investigating this issue.
Posted
Apr
09
,
2025
-
14:49
BST
This incident affected: Internet Network (Essex).
×
Subscribe to Incident
Subscribe to updates for
Cabinet Issue - Cavendish, Sudbury, Suffolk
via . You'll receive .