Unplanned Incident - Waltham Abbey
Incident Report for Gigaclear
Resolved
This incident has been resolved and all services are now back online. We have been monitoring the services since the issue. If you are still having issues please reboot your router and if the issues persist then call our customer care team on 01865591131.
Posted Jun 08, 2021 - 16:18 BST
Investigating
We been have informed us that there is an issue with the service in your area. Our engineers are investigating what has caused the problem and are doing everything they can to restore your service as quickly as possible.
Posted Jun 08, 2021 - 09:29 BST
This incident affected: Internet Network (Essex).