Sunningwell, Abingdon

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 07:25 BST

Update

We are continuing to investigate this issue.
Posted Apr 25, 2025 - 07:24 BST

Investigating

Gigaclear Networks have informed us that there is an issue with the service in your area. Our engineers are investigating what has caused the problem and are doing everything they can to restore your service as quickly as possible.
Posted Apr 25, 2025 - 06:37 BST
This incident affected: Internet Network (Oxfordshire).