Network Issue - Grezeley Green
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 18:15 GMT
Investigating
Due to the fading light and traffic increase, our engineering team working on site had to leave for this evening. Engineers will be attending site tomorrow to complete the work and restore all affected services. We apologize for any inconvenience caused.
Posted Jan 22, 2021 - 18:58 GMT