Blisworth, Northamptonshire
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 12:07 BST
Investigating
Our teams have identified a fault currently affecting services in the Blisworth area. We have engaged our Direct Labour Team and our engineers will be on-site shortly to investigate the root cause of this issue and implement any repairs as quickly as we can.

Please accept our apologies for any inconvenience caused.
Posted Apr 09, 2024 - 12:04 BST
This incident affected: Internet Network (Northamptonshire).