Unplanned Incident - Devon
Incident Report for Gigaclear
Resolved
This incident is now resolved.
Posted Mar 26, 2021 - 17:34 GMT
Identified
The issue has been identified as a power outage with a 3rd party supplier which should be resolved this evening.
Posted Mar 26, 2021 - 15:39 GMT
Investigating
We are aware of an incident affecting services in Devon. We are currently investigating the issue and will post any further updates on this page as soon as we have them. We do not currently have an estimated time of repair.
Posted Mar 26, 2021 - 13:12 GMT
This incident affected: Internet Network (Devon & Somerset).