Cabinet issue - Rowney Green

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 22:32 BST

Identified

We’ve now identified the cause of the service issue and our engineers are working hard to fix the problem and restore your broadband service as quickly as possible. The reason for the loss of service was a Virgin Media backhaul failure, which is currently affecting multiple customers in the area. Our network team is actively working with Virgin Media to resolve the fault, and we are monitoring progress closely to ensure your connection is restored at the earliest opportunity.

We’re very sorry for the disruption this has caused and appreciate your patience while we work to bring your service back online.
Posted Aug 21, 2025 - 15:56 BST

Investigating

We are investigating an issue affecting customers attached to the cabinet in Rowney Green.

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted Aug 21, 2025 - 13:52 BST
This incident affected: Internet Network (Worcestershire).