Network issue - Somerset
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Nov 23, 2021 - 14:34 GMT
Investigating
We have detected an issue affecting multiple cabinets and customers connected to them in Somerset. We
are working on an issue with power supply to critical hardware in the area.

We will update this page with further information as soon as we have identified the fault. We do not currently have an estimated time of recovery.
Posted Nov 23, 2021 - 12:35 GMT
This incident affected: Internet Network (Devon & Somerset).