Cambridgeshire & Huntingdonshire

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Dec 21, 2025 - 06:51 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 21, 2025 - 06:51 GMT

Update

Works have been confirmed to go throughout the night with traffic management planned overnight in aid of restoring service, this means you will not have service tonight. We are very sorry for this and we will have further updates tomorrow morning.
Posted Dec 20, 2025 - 17:06 GMT

Update

We should be receiving an imminent update in regards to the ongoing works to restore connection, thank you for your patience and we are terribly sorry for the inconvenience.
Posted Dec 20, 2025 - 16:32 GMT

Update

We are continuing to work on a fix for this issue.
Posted Dec 20, 2025 - 15:57 GMT

Update

Works are still ongoing for the repairs with a further update being sent out within the next 30 minutes.
Posted Dec 20, 2025 - 15:39 GMT

Update

All engineering teams are on site further investigating the issue, we should have a further update within the next hour or so. We are terribly sorry and working as quickly as we can to bring your connection back up.
Posted Dec 20, 2025 - 14:49 GMT

Update

Works are continuing to fix the issues and we have more engineers dispatched to site. we should have a further update within the next 2 hours. Thank you for your continued patience.
Posted Dec 20, 2025 - 13:11 GMT

Update

Engineers are confirmed to be on site and actively working to a resolution. Updates to follow soon.
Posted Dec 20, 2025 - 11:00 GMT

Identified

The issue has been identified as an issue with the backhaul to our cabinets, the fault has been logged and we will continue to provide updates as and when we have them. Thank you for your continued patience.
Posted Dec 20, 2025 - 10:35 GMT

Investigating

We are aware of an issue within your area and are looking into it as we speak, further communication will follow shortly. We are sorry for any inconvenience caused.
Posted Dec 20, 2025 - 09:38 GMT
This incident affected: Internet Network (Cambridgeshire & Huntingdonshire).