Thank you for your continued patience. Our engineers are back on site this morning to resume restoration work.
Posted Mar 27, 2025 - 09:01 GMT
Update
We apologise for the service disruption. Our engineers will be back on-site the morning of 27.03.25 to continue restoration work.
Posted Mar 26, 2025 - 15:18 GMT
Update
We are continuing to work on the fix this morning, further updates will follow. Thank you for your continued patience.
Posted Mar 26, 2025 - 07:34 GMT
Update
Our engineers have identified the damaged fibre and are now in the process of arranging traffic management to facilitate repairs. Once this is confirmed, we will provide an estimated repair time. We appreciate your understanding and apologise for the disruption to your service.
Posted Mar 25, 2025 - 14:33 GMT
Update
We are aware of the service disruption affecting broadband today. Our engineers are actively investigating the issue to identify the root cause. Rest assured, we are doing everything we can to resolve this as quickly as possible. We appreciate your patience and will restore your service as soon as we can.
Posted Mar 25, 2025 - 11:38 GMT
Identified
We are aware of an issue currently affecting services in the Eversley area. Our engineers will be on-site today, working diligently to restore service as soon as possible. We apologise for any inconvenience this may cause and appreciate your patience.
Posted Mar 25, 2025 - 08:28 GMT
This incident affected: Internet Network (Berkshire).