Your service is now back online as this outage has been resolved. Thank you for your continued patience, if you're still experiencing issues, please raise a case on our customer portal.
Posted Dec 17, 2025 - 17:35 GMT
Update
Thank you for your ongoing patience. Work to restore your service is currently in progress. We apologise for the disruptions caused.
Posted Dec 16, 2025 - 16:19 GMT
Investigating
We have detected an issue affecting multiple cabinets and customers connected to them in Sezincote, Longborough , Bourton-on-the-hill and Moreton in Marsh Centre ( South-West). Our engineers are investigating the cause.
We will update this page with further information as soon as we have identified the fault. We do not currently have an estimated time of recovery.
Posted Dec 16, 2025 - 11:16 GMT
This incident affects: Internet Network (Gloucestershire).