Cabinet Outage - Somerset

Incident Report for Gigaclear

Resolved

Good news, our engineers have now fixed the issue and your service has now been fully restored. You should be able to access your broadband service as usual.
Posted Dec 07, 2025 - 15:00 GMT

Monitoring

Services should now be restoring following the on-site work carried out by our engineering teams. All affected systems are coming back online, and customers should now be seeing service recovery.

We will continue to closely monitor performance to ensure stability. If you are still experiencing any issues, please let us know.
Posted Dec 07, 2025 - 14:23 GMT

Identified

Engineers are on-site and are working to restore services as quickly as possible. Thank you for your ongoing patience.
Posted Dec 07, 2025 - 13:26 GMT

Update

Our teams are actively working to restore service as a top priority. Specialists are on their way to the affected site to carry out necessary checks and corrective actions.

We are closely monitoring progress and will continue to provide updates as the situation develops.
Posted Dec 07, 2025 - 11:29 GMT

Investigating

Our teams have identified a network fault currently affecting services in this area. We have engaged our Direct Labour Team who are investigating the root cause of this issue, and will implement any repairs as quickly as possible. Please accept our apologies for any inconvenience caused.
Posted Dec 07, 2025 - 10:50 GMT
This incident affected: Internet Network (Devon & Somerset).