We appreciate your continued patience while we work to resolve this complex issue. Our backhaul network sustained significant damage following local authority roadworks. A repair plan is now in motion, and crews will be working throughout the night.
Posted Apr 20, 2026 - 15:30 BST
Investigating
We are currently investigating service interruption affecting users in the Harbury & Southam areas of Warwickshire. Our engineers are working to resolve the issue as quickly as possible. We will provide further updates as more information becomes available. We apologise for the inconvenience and appreciate your patience.
Posted Apr 20, 2026 - 09:43 BST
This incident affected: Internet Network (Warwickshire).