South Leigh (South East) - Power Outage

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 11:28 BST

Update

Engineers are going to site with a generator and shall arrive in the early evening. Thank you for patience.
Posted Oct 18, 2025 - 16:35 BST

Identified

We are aware of a power issue with this cabinet, we are working to restore the power and this should be back up as soon as possible. Thank you for your patience. Sorry for any inconvenience caused.
Posted Oct 18, 2025 - 15:38 BST
This incident affected: Internet Network (Oxfordshire).