Churchill, Chipping Norton
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 13:55 GMT
Investigating
Our teams have identified an offline cabinet currently affecting services in the Churchill area. We have engaged our Direct Labour Team, who will be working diligently to review the fault and implement service restoration as quickly as possible.

Please accept our apologies for any inconvenience caused.
Posted Mar 14, 2024 - 12:07 GMT
This incident affected: Internet Network (Oxfordshire).