Our engineers are still on site and continuing to work to resolve the issue affecting service in your area. We apologise for the disruption and will provide further updates as they become available.
Posted Jul 14, 2026 - 15:26 BST
Update
Our engineers are currently on site working to resolve an issue affecting service in your area. We will provide further updates as more information becomes available. We apologise for the disruptions caused.
Posted Jul 14, 2026 - 11:38 BST
Investigating
We are currently investigating service interruption affecting users in the Shipton- Milton Under-Wychwood area. Our engineers are working to resolve the issue as quickly as possible. We will provide further updates as more information becomes available. We apologise for the inconvenience and appreciate your patience.
Posted Jul 14, 2026 - 09:23 BST
This incident affected: Internet Network (Oxfordshire).