Service Upgrade

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Sep 25, 2026 - 19:37 BST

Identified

A planned upgrade will take place between 11:00 PM on 23/09 and 1:00 AM on 24/09. If you experience any service issues after the upgrade, please reboot your wall-mounted box by switching it off, waiting a few seconds, and then turning it back on. If the issue persists after rebooting, please get in touch and we'll be happy to help.
Posted Sep 23, 2026 - 20:01 BST
This incident affected: Network Services (Core Network).