Service issues at Titchmarsh
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Jul 19, 2020 - 15:27 BST
Investigating
We’ve now identified the cause of the service issue and our engineers are working hard to fix the problem and restore your broadband service as quickly as possible. The reason for the loss of service was Card Failure at the Street Cabinet.

As soon as we have more information, we’ll let you know when to expect your broadband service to be up and running again.

We understand that any loss of service may be inconvenient, therefore we appreciate your patience and apologise for any disruption.

Kind Regards,

The Gigaclear team
Posted Jul 19, 2020 - 12:47 BST
This incident affected: Internet Network (Northamptonshire).