We apologise for the continued disruption. Our engineering teams have successfully repaired the infrastructure damage, and fiber teams will be working through the evening to complete the splicing. We appreciate your ongoing patience.
Posted Apr 07, 2026 - 18:41 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 07, 2026 - 14:25 BST
Update
Our engineers are currently on site working to resolve an issue affecting service in your area. We apologise for the disruptions caused.
Posted Apr 07, 2026 - 10:50 BST
Update
Thank you for your ongoing patience. Our team is scheduled to be on-site this morning, looking to restore your service. We'll keep you updated as work progresses. Sorry for the disruption.
Posted Apr 07, 2026 - 08:36 BST
Update
We are continuing to investigate this issue.
Posted Apr 06, 2026 - 19:30 BST
Investigating
We are investigating an issue affecting customers attached to the cabinet in the Outer Bledington & Adlestrop areas.
Updates will be posted here as soon as the fault has been identified.
Posted Apr 06, 2026 - 16:55 BST
This incident affected: Internet Network (Gloucestershire, Oxfordshire).