Customer Operations Phone issue
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted May 03, 2022 - 14:59 BST
Investigating
We have been made aware of an issue with Customers calling into Gigaclear,
We apologise for any inconvenience caused whilst we investigate and resolve.

Kind Regards
The Gigaclear team
Posted May 03, 2022 - 13:26 BST
This incident affected: Customer Care.