Oddington, Murcott & Charlton-on-Otmoor - Oxfordshire

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 12:45 BST

Update

We have scheduled our Direct Labour Team to attend tomorrow morning to begin investigating the root cause of this issue, and will implement any repairs as quickly as possible. Please accept our apologies for any inconvenience caused.
Posted Mar 30, 2026 - 16:02 BST

Identified

We are aware of an issue causing slow speeds and intermittent connectivity in the Oddington, Murcott & Charlton-on-Otmoor areas of Oxfordshire. Our network team are investigating. We apologise for the inconvenience and appreciate your patience.
Posted Mar 30, 2026 - 14:49 BST
This incident affected: Internet Network (Oxfordshire).