Kelvedon (Essex)

Incident Report for Gigaclear

Identified

Our engineers are on-site, and connectivity has been restored for the majority of customers. We are continuing to work on restoring service to the remaining affected users. We appreciate your patience and apologise for the inconvenience.
Posted Jun 24, 2026 - 18:25 BST

Investigating

We are currently investigating service interruption affecting users in the [Kelvedon (East) area. Our engineers are working to resolve the issue as quickly as possible. We will provide further updates as more information becomes available. We apologise for the inconvenience and appreciate your patience.
Posted Jun 24, 2026 - 14:07 BST
This incident affects: Internet Network (Essex).