Network Issue - Kirtlington
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Jan 15, 2021 - 16:13 GMT
Investigating
We've identified a failure within the cabinet serving the Kirtlington community, our field teams are on their way and will have the issue resolved soon.

Thank you for your patience.
Posted Jan 15, 2021 - 13:56 GMT
This incident affected: Internet Network (Oxfordshire).