Duddenhoe End - Essex - DUD01
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 16:55 GMT
Update
Our team are working hard to restore your service. We are aiming to restore your service by 5pm today.

Thank you for your continued patience.
Posted Nov 07, 2024 - 15:05 GMT
Investigating
We have identified a fault in the network. Our team are working on a solution and we aim to restore service asap. As soon as we have an estimated restoration time, we will let you know. Sorry for any disruption and thank you for your continued support.
Posted Nov 07, 2024 - 10:11 GMT