The link has been restored and both cabinets are coming back online. Once services recover, we'll check for any customers still affected. Thank you for your continued patience, further works to be done.
Posted Aug 04, 2026 - 14:17 BST
Update
Restoration works are progressing on schedule. We are expecting to have all services restored today. Please leave your equipment switched on to assist with the resolution. Further updates will be relayed upon being made available.
Posted Aug 04, 2026 - 13:19 BST
Update
Our engineers are on site and continuing work to identify the affected fibre connections and assess the required remediation work. Preparation for the traffic management is ongoing, with the team expected on site within the hour. Thank you for your continued patience and we will provide more updates as they become available.
Posted Aug 04, 2026 - 11:32 BST
Update
Our traffic management crew will be on site shortly to enable our engineers to continue repairs on the affected part of the network. A further update will be provided once made available from the engineers on site. We sincerely apologise for any inconvenience this issue may have caused and appreciate your patience while we work to restore service as quickly as possible.
Posted Aug 04, 2026 - 10:46 BST
Update
Our engineers are due to be on site shortly to continue working towards a resolution for this ongoing loss of service. We are aligning specialist equipment and permits for this attendance. We appreciate your understanding and patience. Further updates will be provided as they come
Posted Aug 04, 2026 - 08:42 BST
Identified
Our engineers have identified a break in the fibre network. The necessary resources have been mobilised, and repair work is scheduled to begin this morning. We will continue to provide updates as progress is made.
Posted Aug 04, 2026 - 08:06 BST
Update
We are continuing to investigate this issue.
Posted Aug 04, 2026 - 00:05 BST
Update
We are continuing to investigate this issue.
Posted Aug 03, 2026 - 23:13 BST
Update
We are continuing to investigate this issue.
Posted Aug 03, 2026 - 22:32 BST
Investigating
We are currently investigating service interruption affecting users in the Great Missenden and Naphill & Lacey Green area. Our engineers are working to resolve the issue as quickly as possible. We will provide further updates as more information becomes available. We apologise for the inconvenience and appreciate your patience.
Posted Aug 03, 2026 - 22:31 BST
This incident affected: Internet Network (Buckinghamshire).