Cabinet Issue - Cinderford

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 20:49 BST

Monitoring

The National Grid has reported a power cut currently impacting your area. They expect power to be restored by 6:00pm this evening.

To maintain your broadband service during this period, we have attached a generator to our cabinet. We are monitoring the situation closely and will provide further updates as needed.

Thank you for your patience and understanding.
Posted Jul 17, 2025 - 14:12 BST