Mathon, Herefordshire

Incident Report for Gigaclear

Update

Thank you for your ongoing patience. Our engineers are currently on-site and will be working throughout today for your restoration. We apologise for the disruption.
Posted Oct 20, 2025 - 11:40 BST

Update

Further works are required and have been planned to start tomorrow morning. Estimated resolution window at this time is end of play Monday, we apologise for any inconvenience caused
Posted Oct 18, 2025 - 15:43 BST

Update

Engineers have been dispatched and their ETA is 10AM to commence works. Thank you for your continued patience.
Posted Oct 18, 2025 - 09:13 BST

Identified

We are aware of an issue affecting services in the Mathon, Herefordshire area, following a vehicle collision involving a network cabinet. We have arranged a team to attend and will work to restore service as quickly as possible. We apologise for any inconvenience this may cause.
Posted Oct 17, 2025 - 18:34 BST
This incident affects: Internet Network (Herefordshire).