Yeovil, Curry Rivel, Langport & Ilchester (Somerset)

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 01:02 BST

Update

Our team will be working with our partner throughout the night to restore full service as quickly as possible. We apologise for the inconvenience caused and greatly appreciate your continued patience and understanding while we work to resolve the issue.
Posted Sep 08, 2026 - 20:01 BST

Identified

We are working alongside our network partners to carry out repairs on the damaged fibre. The team are progressing and have prepared the fibre for splicing. We will provide a further update once it is made available. Thank you for your continued patience while we work to resolve the issue.
Posted Sep 08, 2026 - 18:27 BST

Update

We’re continuing to investigate the service interruption affecting your connection. Our teams are working with our network partners, who have confirmed that a wider issue with a third-party provider is currently impacting multiple services.

Our teams are actively working with the third party to identify and resolve the fault, we will provide further updates as soon as more information becomes available. Thank you for your patience and understanding.
Posted Sep 08, 2026 - 13:36 BST

Investigating

We are currently investigating service interruption affecting users in the Yeovil, Curry Rivel, Langport & Ilchester areas of Somerset. Our engineers are working to resolve the issue as quickly as possible. We will provide further updates as more information becomes available. We apologise for the inconvenience and appreciate your patience.
Posted Sep 08, 2026 - 12:00 BST
This incident affected: Internet Network (Somerset).