Customer Operations phoneline issues
Incident Report for Gigaclear
Resolved
This issue is resolved and the phonelines are operating normally
Posted Jun 17, 2022 - 15:55 BST
Monitoring
Our phonelines are now open and we are able to receive calls. We are monitoring the situation closely for any further issues.
Posted Jun 16, 2022 - 13:58 BST
Investigating
We are currently experiencing an issue affection our Customer Operations department's phone lines. We are investigating this as a matter of urgency, but currently cannot receive any calls from customers. We will update this page when we have more information.
Posted Jun 16, 2022 - 13:33 BST
This incident affected: Customer Care.