Croford, Somerset, SW-CRFR
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 14:30 GMT
Investigating
Our networks team have identified a fault currently affecting services in the Croford, Somerset area. We have engaged our Direct Labour Teams, and engineers will be on-site for midday investigating the root cause and implementing any repairs as quickly as we can.

Thank you for your patience.
Posted Nov 07, 2024 - 11:48 GMT
This incident affected: Internet Network (Devon & Somerset).