Newton Bromswold, Northamptonshire

Incident Report for Gigaclear

Update

Works are still ongoing as we aim to restore all connections this evening. Please ensure your Gigaclear equipment is powered on and be aware that engineers may come to your property to test the external cabling for signal throughout the day. We will continue to update and thank you for your continued patience and understanding.
Posted Dec 05, 2025 - 16:00 GMT

Update

Restoration works continue throughout the day today. Please keep your equipment powered on and plugged in. Please be aware our engineers will be testing at properties. Estimated time for restoration is still tonight, more updates to follow this afternoon. Thank you for your continued patience.
Posted Dec 05, 2025 - 09:51 GMT

Update

Restoration work is underway, and our engineers are working diligently together with third party power provider to reconnect services following the cabinet damage. Thank you for your patience and understanding. We’ll provide further updates as soon as possible.
Posted Dec 04, 2025 - 13:47 GMT

Update

Thank you for your ongoing patience. Replacement infrastructure is on it's way to the site for our engineers to begin work to restore full service. We apologise for the inconvenience and disruption this unforeseen incident has caused.
Posted Dec 04, 2025 - 09:26 GMT

Identified

The outage is due to physical damage to one of our network cabinets caused by a vehicle impact.

Our engineers are already on site and are working as quickly and safely as possible to restore full service.

We apologise for the inconvenience and disruption this unforeseen incident has caused. Thank you for your understanding and patience.
Posted Dec 03, 2025 - 08:19 GMT

Investigating

We are investigating an issue affecting customers attached to the cabinet in Newton Bromswold, Northamptonshire.

Updates will be posted here as soon as the fault has been identified.
Posted Dec 03, 2025 - 07:02 GMT
This incident affects: Internet Network (Northamptonshire).