Oxfordshire
Incident Report for Gigaclear
Resolved
Service has now been fully restored. You should be able to access your broadband service as usual.

What do I need to do?

You don’t need to do anything as your broadband service will resume as normal. However, if you find your broadband service isn’t working properly, please try rebooting your router. You can do this by turning the power off at the socket, waiting for approximately 30 seconds and then switching the power back on.

What if I have a problem?

If you have any problems with your broadband service, then please don’t hesitate to contact our Customer Support team on 01865 591131 or by emailing support@gigaclear.com.

We thank you for your patience during this time and apologise for any disruption caused.
Posted May 12, 2021 - 08:51 BST
Update
The issue has been identified with the third party backhaul supplier, and is still ongoing. We apologise for the continued delay and will keep you updated as this progresses.

The Gigaclear Team
Posted May 12, 2021 - 07:16 BST
Update
The issue has been identified with the third party backhaul supplier, who are investigating the issue. We apologise for any inconvenience caused.

The Gigaclear Team
Posted May 12, 2021 - 07:11 BST
Identified
The issue has been identified with the third party backhaul supplier.
Posted May 12, 2021 - 03:30 BST
This incident affected: Internet Network (Oxfordshire).