Unplanned Outage Somerset and Devon

Incident Report for Gigaclear

Resolved

Good news, our engineers have now fixed the issue and your service has now been fully restored. You should be able to access your broadband service as usual.
Posted Dec 10, 2025 - 23:12 GMT

Update

We have both our direct and partner engineers on site working on the fix as we speak. We will be working through the night however, we don't expect any customers to be back online tonight.
Posted Dec 10, 2025 - 19:14 GMT

Update

We have further support coming to help with the fix from our partners attending early this evening, further updates will follow from here.
Posted Dec 10, 2025 - 17:06 GMT

Update

We are continuing to work on fixing the issue. We are seeking further assistance from our partners to resolve this as quickly as we can. Thank you for your continued patience.
Posted Dec 10, 2025 - 15:36 GMT

Identified

The issue has been identified and we are working with our partners to fix this as soon as we can. Thank you again for your continued patience whilst we get this resolved.
Posted Dec 10, 2025 - 14:07 GMT

Update

Thank you for your ongoing patience. Work to restore your service is currently in progress. We apologise for the disruptions caused.
Posted Dec 10, 2025 - 13:53 GMT

Update

Engineers have been dispatched with an estimated time of arrival of 1PM. We are committed to getting this fixed as soon as we possibly can.
Posted Dec 10, 2025 - 12:11 GMT

Investigating

We are aware of an issue within the area and are investigating the cause. Our network engineers are working on it as we speak and we will get an ETA for when we have engineers on the ground shortly. We are terribly sorry for any inconvenience caused.
Posted Dec 10, 2025 - 11:50 GMT
This incident affected: Internet Network (Devon & Somerset).