Our engineers are on-site to restore all affected customers and will begin the repair work this afternoon. Please ensure that all of your equipment is switched on and connected to allow us to expedite the outage resolution. Thank you for your ongoing patience
Posted Mar 03, 2026 - 13:18 GMT
Identified
We have identified that a third-party construction incident caused a fibre break. Our engineers are working to repair the damage as quickly as possible. We appreciate your continued patience.
Posted Mar 03, 2026 - 12:32 GMT
Investigating
We’re aware of service issues in Oakley & Brill, Buckinghamshire. Our engineers are investigating, and we’ll share updates here as soon as we have them. We apologise for the disruption and appreciate your patience.
Posted Mar 03, 2026 - 10:24 GMT
This incident affects: Internet Network (Buckinghamshire).