Billing and payment issue

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 16:40 BST

Investigating

We are currently experiencing some issues with our billing and payment services, which may result in some customers being incorrectly informed that they have an outstanding balance. We are investigating the issue and if you have received this email, please do not make any manual payments. Thank you for your patience.
Posted Apr 21, 2025 - 10:38 BST