Our team will be working through the weekend to conduct excavation work. Once completed, we will lay and connect the new fibre to our network. We appreciate your patience and apologise for the inconvenience.
Posted Jun 12, 2026 - 10:59 BST
Investigating
We apologise for the ongoing service disruption caused by a falling tree that damaged multiple poles. Openreach (the pole owner) has scheduled the replacement for June 24th - however, we are actively working on an alternative plan to restore your service sooner. Thank you for your continued patience.
Posted Jun 12, 2026 - 08:17 BST
This incident affects: Internet Network (Norfolk).