Brimpton - Berkshire

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 15:35 BST

Update

Engineers are currently still on-site carrying out works. We will provide further updates when they are available. Thank you for your understanding and patience while we work to resolve the issue.
Posted Apr 01, 2026 - 13:16 BST

Update

We apologise for the continued loss of service. Unfortunately, local authority roadworks have caused significant damage to our network cables. We have both civils and fiber teams on-site today dedicated to fixing the issue. Thank you for your patience.
Posted Apr 01, 2026 - 08:54 BST

Identified

Civils works have been scheduled for tomorrow to continue working on a resolution for this ongoing loss of service. Thank you for your patience whilst we work on a resolution
Posted Mar 31, 2026 - 15:09 BST

Update

Engineers are currently still on-site carrying out works. We will update you on a estimated resolution time and further information regarding the nature of the network outage. Thank you for your understanding and patience while we work to resolve the issue.
Posted Mar 30, 2026 - 18:26 BST

Update

Our team are scheduled to be on site shortly to begin investigating the issue and will implement any repairs as quickly as possible. Thank you for your patience.
Posted Mar 30, 2026 - 16:01 BST

Investigating

We are aware of an issue impacting service in the Brimpton area of Berkshire. Our network team are investigating. We apologise for the inconvenience and appreciate your patience.
Posted Mar 30, 2026 - 15:02 BST
This incident affected: Internet Network (Berkshire).