Service Degregation - Essex
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 08:10 GMT
Identified
We are aware of latency issues across our Essex Network, which may cause degregation in customer broadband speeds and our Voice services.

Gigaclear engineers are on site and working to resolve this isssue, but at this time we do not have an estimated time of repair.

We thank you for your patience while we work to restore services.
Posted Mar 13, 2024 - 19:26 GMT
This incident affected: Internet Network (Essex).