Unplanned incident in Godden Green
Incident Report for Gigaclear
Resolved
All services have no been restored, there should be no further problems in the area.
Posted Jun 14, 2021 - 10:35 BST
Identified
We are aware of an issue affecting services in Godden Green and the surrounding area. Our engineers are on the way to the site to look into this further, but we do not currently have an estimated time of repair. We will post any further updates on this page.
Posted Jun 14, 2021 - 09:26 BST
This incident affected: Internet Network (Kent).