This incident has now been resolved, thank you for your patience.
Posted Aug 13, 2026 - 10:16 BST
Monitoring
A fix is being implemented as we speak and we are starting to see customers come back online, thank you for your patience. We will continue to monitor until this is confirmed as resolved.
Posted Aug 13, 2026 - 08:36 BST
Identified
We are aware of an issue which has caused a disconnection of the broadband services, we are working tirelessly to get this fixed. Next update by 9AM. We are very sorry for the issue caused.
Posted Aug 13, 2026 - 08:25 BST
This incident affected: Network Services (Core Network).