Our engineers are scheduled to attend the site this evening to carry out further investigation into the issue. We will provide additional updates as soon as more information becomes available.
Posted Apr 15, 2026 - 19:37 BST
Investigating
Our teams have identified a network fault currently affecting services in your area. We have engaged our Direct Labour Team who are investigating the root cause of this issue, and will implement any repairs as quickly as possible. Please accept our apologies for any inconvenience caused.
Posted Apr 15, 2026 - 18:48 BST
This incident affected: Internet Network (Herefordshire).