Degradation - Northamptonshire Area 2
Incident Report for
Gigaclear
Resolved
This incident has been resolved.
Posted
Jun
26
,
2025
-
15:29
BST
Identified
Unfortunately today we are having service degradation in your area, our teams are working diligently to resolve this.
We are very sorry for the disruption to your service.
Posted
Jun
25
,
2025
-
15:55
BST
This incident affected: Internet Network (Northamptonshire).
×
Subscribe to Incident
Subscribe to updates for
Degradation - Northamptonshire Area 2
via . You'll receive .