Service Issues in Eddington
Incident Report for Gigaclear
Resolved
Gigaclear operations have confirmed that all services have been restored.
Posted Jun 25, 2020 - 17:35 BST
Update
Our Engineers are on site and have begun the remedial works, we're on track to see services restore from midday.

Thank you for your patience.
Posted Jun 25, 2020 - 09:03 BST
Identified
We've identified a cable break serving our community in Eddington, the location of the break has been located and a repair plan put in place for the morning of 25/06/2020. We anticipate customers returning to service from midday.

Thank you for your patience.
Posted Jun 24, 2020 - 16:30 BST
This incident affected: Internet Network (Berkshire).