East Charlbury, Oxfordshire
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 11:44 GMT
Investigating
Our teams have identified an offline cabinet currently affecting services in the East Charlbury area. Our Direct Labour Team have been engaged and will be working diligently to identify the root cause of this issue and implement all resolutions as quickly as we can.

Please accept our apologies for any inconvenience caused.
Posted Mar 19, 2024 - 11:18 GMT
This incident affected: Internet Network (Oxfordshire).