Thank you for your patience, works are still underway replacing the faulty component, next update will be within the next 2 hours.
Posted May 28, 2026 - 18:57 BST
Update
We are awaiting an update from site to ascertain the progress of the repair. We will update in due course.
Posted May 28, 2026 - 18:15 BST
Identified
We are terribly sorry for the inconvenience caused, our teams have identified a faulty component in the cabinet and the ETA for this is at 6PM. We thank you for your continued patience.
Posted May 28, 2026 - 17:40 BST
This incident affected: Internet Network (Somerset).