Cabinet issue - Grafton Underwood (East Midlands)
Incident Report for
Gigaclear
Resolved
This incident has been resolved.
Posted
Nov
14
,
2024
-
09:03
GMT
Investigating
We are investigating an issue affecting customers attached to the cabinet in Grafton Underwood (East Midlands).
Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted
Nov
13
,
2024
-
19:26
GMT
This incident affected: Internet Network (Northamptonshire).
×
Subscribe to Incident
Subscribe to updates for
Cabinet issue - Grafton Underwood (East Midlands)
via . You'll receive .