Cabinet issue - Ivington (West Midlands)
Incident Report for
Gigaclear
Resolved
Our team have implemented a Temp fix.
If you are having connection issues please speak with us at gigaclear.com/chat
Posted
Nov
14
,
2024
-
15:39
GMT
Investigating
We are investigating an issue affecting customers attached to the cabinet in Ivington (West Midlands).
Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted
Nov
12
,
2024
-
13:58
GMT
This incident affected: Internet Network (Herefordshire).
×
Subscribe to Incident
Subscribe to updates for
Cabinet issue - Ivington (West Midlands)
via . You'll receive .