Cabinet issue - Clapton on the Hill (GL54 3DY)
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted 9 days ago. Sep 10, 2019 - 01:38 BST
Investigating
We are investigating an issue affecting customers attached to the cabinet in Clapton on the Hill. GL54 3DY

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted 13 days ago. Sep 06, 2019 - 08:39 BST